ORE-27 L1A and L1B Processing Failure Recovery

Note to the Reviewer: This Draft ORE is initially based on nominal occurrences of separate L1A/L1B MODIS Processing and Archive (as provided by Steve Berrick’s comments for ORE’s 3 and 6).  My thought is that errors/failures could be introduced to the following steps and recovery steps could be red-lined.  If not practical, comment in a manner that works best for you.  I can adjust.  As a side, note Objectives 1 and 2 of this ORE will be incorporated into ORE’s 3 and 6 respectively.

ORE-27: L1A and L1B Processing Failure Recovery 

This ORE will exercise the following operational scenarios; (1) recovery from failure in any of the processing steps from L1A and (2) recovery from failure in any of the processing steps from L1B.

Exercise Assumptions:

· Objective #1:

1. All necessary ECS servers are up and running.

2. The Resource Plan has already been generated.

3. All necessary ODL files for MODIS PGE01 have been generated.

4. All necessary ESDTs have been installed:

All System ESDTs (PGEEXE, DAP, PH, SSAP, etc.) MOD00,  MOD01, MOD01LUT, MOD03LUT, AM1EPHN0,  AM1ATTN0

· Objective #2

1. All necessary ECS servers are up and running.

2. The Resource Plan has already been generated.

3. All necessary ODL files for MODIS PGE02 have been generated.

4. All necessary ESDTs have been installed:

All System ESDTs (PGEEXE, DAP, PH, SSAP, etc.) MOD01, MOD02LUT ,MOD021KM, MOD02HKM, MOD02QKM,  MOD02OBC

ORE Data Sets:

TBD

ORE-27 Procedures:

ORE-27: Step-By-Step Procedures

Objective #1 L1A Processing Failure Recovery

Step No.
Position
Operational Instruction and Response/Expected Result

* PGE Registration

1
Production Monitor/SSI&T Specialist
o Log into DCE on g0ais01

        - telnet g0ais01

            login: opsuser

            password: ********

        - dce_login opsuser opsuser

2
Production Monitor/SSI&T Specialist
o Confirm that required ODL files for this PGE exist in correct location

        - cd /usr/ecs/OPS/CUSTOM/data/DPS/ODL

        - ls PGE_MoPGE01#1#01.odl

        - ls ESDT_MOD00#001.odl ESDT_MOD01LUT#001.odl ESDT_MOD03LUT#001.odl \

          ESDT_AM1EPHN0#001.odl ESDT_AM1ATTN0#001.odl ESDT_MOD01#001.odl \

          ESDT_MOD03#001.odl

    o Start the SSIT Manager GUI on g0ais01

        - cd /usr/ecs/OPS/CUSTOM/utilities

        - setenv DISPLAY <current terminal>:0.0 (if necessary)

        - EcDpAtMgrStart OPS

3
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI:

        - Select Tools -> PDPS Database -> SSIT Science Metadata Update        

        - Configuration filename?   Hit return for default     

        - ECS Mode of operations?     OPS 

        - PGE name (max 10 characters)?  MoPGE01 
        - PGE version (max 5 characters)?     1

        - PGE Profile ID (0-99, 0 means null)?    1

4
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI:

        - Select Tools -> PDPS Database -> SSIT Opnl Metadata Update

        - Click on NEW PGE button (bottom left)

        - Select 'MoPGE01' from the PGE Names window 

        - Select '1' from the PGE Versions window

        - Click on the EDIT button

        - Click on the PROFILE tab

        - Fill in the Performance Statistics (the following assume that PGE01 is

          a 15-min PGE):

            Wall clock time: 7710

            CPU time (user): 7245
            Max memory used: 113.0
            Block input ops: 73365
            Block output ops: 183

            Swaps: 0
            Page faults: 21            



5
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI: (continued)

             DISK SPACE used for PGE run: 8500.0
            Number of CPUs: 1
            - Click on Proc. String radio button and then select a processor from the window next to it.

            - Local filename of top level shell: PGE01.csh
            - Select SGI Application Binary Interface (ABI): 64-bit

            - Set the following Toolkit Initialization Settings:

                Shared Memory: on
                Use Log Files: on
                Use Text Files if SM Fails: on
                Continue if Logging fails: off

        - Click on the APPLY button.

        - Select the File menu, and then Exit.

Insert the PGE Executable Tar File

6
Production Monitor/SSI&T Specialist
o In SSIT Manager GUI on g0ais01:

        - Select Tools -> Data Server -> Insert EXE Tar
        - Configuration filename?    Hit return for default
        - ECS Mode of operations?     OPS
        - Name of PGE?   MoPGE01

        - Science software version of PGE?      2.1
        - Staged filename to insert (including FULL path)?    <tar file full pathname>

        - Associated ASCII metadata filename to insert (including FULL path)?   <metadata full pathname>
        - Top level shell filename within tar file?  PGE01.csh

Insert the PGE Static Files

7
Production Monitor/SSI&T Specialist
o In SSIT Manager GUI on g0ais01:

        - Select Tools -> Data Server -> Insert Static

        - Configuration filename?   Hit return for default
        - ECS Mode of operations?    OPS

        - ESDT Short Name for the file(s) to insert? MOD01LUT

        - ESDT Version of the file(s) to insert?     001

        - Science Group for the Static file (one of {C,L,D,O} followed by a 3 digit number)?   L1
        - Is there more than one data file for this Static (Y=yes,N=No)?      N
        - Single Static Filename to Insert (including FULL path)?       <path>/ENG_DATA_LIST.coeff
        - Associated ASCII Metadata Filename to Insert (including FULL path)?  <path>/<filename>.met
        - Hit return to continue or q to quit      Hit return


8
Production Monitor/SSI&T Specialist
- Configuration filename?   Hit return for default
        - ECS Mode of operations?    Hit return or type: OPS
        - ESDT Short Name for the file(s) to insert?    MOD03LUT

        - ESDT Version of the file(s) to insert?   Hit return or type: 001

        - Science Group for the Static file (one of {C,L,D,O} followed by a 3 digit number)?     L2

        - Is there more than one data file for this Static (Y=yes,N=No)?      N

        - Single Static Filename to Insert (including FULL path)?        <path>/GEO_parameters.coeff
        - Associated ASCII Metadata Filename to Insert (including FULL path)?   <path>/<filename>.met
        - Hit return to continue or q to quit      q

Make Snapshot of the PDPS database

9
Production Monitor/SSI&T Specialist
    o Log onto g0pls01

    o Save the database 

        - cd /usr/ecs/OPS/CUSTOM/utilities

        - list_db

        - Verify that the name under which to save the database doesn't already exist

        - save_db <database name>

        - vi README.saved_databases

        - Add the name under which you saved the database to the list and follow with a description



Insert the PGE Dynamic Files

10
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI:

        - Select Tools -> Data Server -> Insert Dynamic

        - Configuration filename?        Hit return for default

        - ECS Mode of operations?            OPS
        - ESDT short name for the file(s) to Insert?         MOD00
        - ESDT Version for the file(s) to insert?            001
        - Is there more than one data file to this Dynamic Granule (Y = Yes, N=No)?       Y
        - Directory where all data files and .met file exist (FULL path)?

            <path to where MOD00 input granules reside>

        - Name of MFG file (enter to end list)?     <filename of first file>

        - Name of MFG file (enter to end list)?      <filename of second file>             

        - Name of MFG file (enter to end list)?      <filename of last file>
        - Name of MFG file (enter to end list)?       Hit return
        - Associated ASCII Metadata Filename to Insert?   <filename of .met file>

        - Hit return to continue or q to quit      Hit return        

11
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI: (Continued)

        - Configuration filename?     Hit return for default
        - ECS Mode of operations?   Hit return for default or type: OPS

        - ESDT short name for the file(s) to Insert?       AM1EPHN0
        - ESDT Version for the file(s) to insert?         001
        - Is there more than one data file to this Dynamic Granule (Y = Yes, N=No)?   N
        - Single Filename to Insert (including FULL path)?  <full pathname of granule>
        - Associated ASCII Metadata Filename to Insert (including FULL path)?    <full pathname of .met file>

        - Hit return to continue or q to quit         Hit return

        - Configuration filename?            Hit return for default

        - ECS Mode of operations?        Hit return for default or type: OPS
        - ESDT short name for the file(s) to Insert?            AM1ATTN0

        - ESDT Version for the file(s) to insert?            001
        - Is there more than one data file to this Dynamic Granule (Y = Yes, N=No)?        N
        - Single Filename to Insert (including FULL path)?            <full pathname of granule>
        - Associated ASCII Metadata Filename to Insert (including FULL path)?

            <full pathname of .met file>

        - Hit return to continue or q to quit    q

 Create a Production Request

13
Production Monitor/SSI&T Specialist
o Log into DCE on g0pls01

        - telnet g0ais01

            login: opsuser

            password: ********

        - dce_login opsuser opsuser

        - setenv DISPLAY <current terminal>:0.0 (if necessary)

        - Verify that all necessary ECS servers are up and running

        - cd /usr/ecs/OPS/CUSTOM/utilities

        - EcPlPRE_IfStart OPS

        - Click on the PR Edit tab

        - Click on the PGE button
        - In the list box, select MoPGE01, version 1, profile ID 1

        - Click on the OK button
        - Enter the dates and times for this run (TBD)

        - Click on the File menu and select Save As
        - Type in the name of the PR in the Selection region: MoPGE01#1#01.<iteration>
        - Click on the OK button
        - Wait for a pop-up window message: "Production Request Explosion into

          DPRs ok. 1 DPRs Generated." and click on the OK button 

        - Close the PR Editor

Bring up Autosys

14
Production Monitor/SSI&T Specialist
o Log onto on g0sps06

        - telnet g0sps06

            login: shareusr

            password: ********



15
Production Monitor/SSI&T Specialist
o Start Autosys

        - setenv ECS_HOME /usr/ecs

        - setenv DISPLAY <current terminal>:0.0 (if necessary)

        - cd /usr/ecs/OPS/CUSTOM/utilities

        - EcDpPrAutosysStart OPS FMR

        - Click on the Ops Console button

        - In the Ops Console window, uncheck the Freeze Frame button 

        - Click on the JobScape button in the main Autosys button window



Create the Production Plan and Execute the PGE

16
Production Monitor/SSI&T Specialist
o Log onto on g0pls01

        - telnet g0pls01

            login: opsuser

            password: ********

        - setenv DISPLAY <current terminal>:0.0 (if necessary)

        - cd /usr/ecs/OPS/CUSTOM/utilities

        - EcPlSlayAll OPS

        - EcPlAllStart OPS 1

        - In Planning Workbench, select File -> Save As

        - Enter plan name (TBD)

        - Click on the OK button

        - In the Unscheduled area of window, click on the PGE01 PR to schedule it

        - Click on the schedule down arrow

        - Click on the Activate button

        - In pop-up window, "You need to save current plan before you activate the plan!!!", click                on Save

Monitor the PGE Execution in Autosys

17
Production Monitor/SSI&T Specialist
o View the Autosys JobScape window and monitor the job box for the DPR running 

18
Production Monitor/SSI&T Specialist
o View the Job Management log file on g0sps06 as the PGE exeuctes:

        - cd /usr/ecs/OPS/CUSTOM/logs

        - tail -f MoPGE01<DPR ID>.err

19
Production Monitor/SSI&T Specialist
o As each job in the job box completes successfully, it will turn blue

20
Production Monitor/SSI&T Specialist
o When entire job box completes successfully, the entire job box will turn blue.

Validate the output products

21
Production Monitor/SSI&T Specialist
o Acquire the output products MOD01 and MOD03, along with the Production History tar file

22
Production Monitor/SSI&T Specialist
o Compare the output with comparison output generated earlier

23
Production Monitor/SSI&T Specialist
o View the Production History tar file 

ORE-27: Step-By-Step Procedures

Objective #2 L1B Processing Failure Recovery

Step No.

Operational Instruction and Response/Expected Result

* PGE Registration

1
Production Monitor/SSI&T Specialist
o Log into DCE on g0ais01

· telnet g0ais01

login: opsuser

password: ********

- dce_login opsuser opsuser

2
Production Monitor/SSI&T Specialist
o Confirm that required ODL files for this PGE exist in correct location

- cd /usr/ecs/OPS/CUSTOM/data/DPS/ODL

- ls PGE_MoPGE02#1#01.odl

- ls ESDT_MOD01#001.odl ESDT_MOD03#001.odl ESDT_MOD02LUT#001.odl \

ESDT_MOD021KM#001.odl ESDT_MOD02HKM#001.odl ESDT_MOD02QKM#001.odl \

ESDT_MOD02OBC#001.odl

3
Production Monitor/SSI&T Specialist
o Start the SSIT Manager GUI on g0ais01

- cd /usr/ecs/OPS/CUSTOM/utilities

- setenv DISPLAY <current terminal>:0.0 (if necessary)

- EcDpAtMgrStart OPS

4
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI:

- Select Tools -> PDPS Database -> SSIT Science Metadata Update

- Configuration filename? Hit return for default
- ECS Mode of operations? OPS
- PGE name (max 10 characters)? MoPGE02
- PGE version (max 5 characters)? 1
- PGE Profile ID (0-99, 0 means null)? 1

5
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI:

- Select Tools -> PDPS Database -> SSIT Opnl Metadata Update
- Click on NEW PGE button (bottom left)

- Select 'MoPGE02' from the PGE Names window

- Select '1' from the PGE Versions window

- Click on the EDIT button

- Click on the PROFILE tab

- Fill in the Performance Statistics (the following assume that PGE02 is a 5-min PGE):

  Wall clock time: 797
  CPU time (user): 344
  Max memory used: 126.0

  Block input ops: 10955
  Block output ops: 48
  Swaps: 0
  Page faults: 48
  DISK SPACE used for PGE run: 2664.0
  Number of CPUs: 1
  Click on Proc. String radio button and then select a processor from the window next to it.

  Local filename of top level shell: PGE02.csh

  Select SGI Application Binary Interface (ABI): new 32-bit

6
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI: (Continued)

-Set the following Toolkit Initialization Settings:

  Shared Memory: on
  Use Log Files: on
  Use Text Files if SM Fails: on
  Continue if Logging fails: off
- Click on the APPLY button.

- Select the File menu, and then Exit.

Insert the PGE Executable Tar File

7
Production Monitor/SSI&T Specialist
o In SSIT Manager GUI on g0ais01:

- Select Tools -> Data Server -> Insert EXE Tar

- Configuration filename? Hit return for default

- ECS Mode of operations? OPS
- Name of PGE? MoPGE02
- Science software version of PGE?  2.0
- Staged filename to insert (including FULL path)? <tar file full pathname>

- Associated ASCII metadata filename to insert (including FULL path)? <metadata full pathname>

- Top level shell filename within tar file? PGE02.csh

Insert the PGE Static Files

8
Production Monitor/SSI&T Specialist
o In SSIT Manager GUI on g0ais01:

- Select Tools -> Data Server -> Insert Static
- Configuration filename? Hit return for default

- ECS Mode of operations? OPS
- ESDT Short Name for the file(s) to insert?  MOD02LUT
- ESDT Version of the file(s) to insert? 001
- Science Group for the Static file (one of {C,L,D,O} followed by a 3 digit number)? L1
- Is there more than one data file for this Static (Y=yes,N=No)? N
- Single Static Filename to Insert (including FULL path)? <path>/Reflective_Lookup_Tables_file.coeff
- Associated ASCII Metadata Filename to Insert (including FULL path)? <path>/<filename>.met
- Hit return to continue or q to quit  Hit return
- Configuration filename? Hit return for default

- ECS Mode of operations? Hit return or type: OPS
- ESDT Short Name for the file(s) to insert? MOD02LUT
- ESDT Version of the file(s) to insert? Hit return or type: 001 

- Science Group for the Static file (one of {C,L,D,O} followed by a 3 digit number)? L2
- Is there more than one data file for this Static (Y=yes,N=No)? N
- Single Static Filename to Insert (including FULL path)? <path>/Emissive_Lookup_Tables_file.coeff
- Associated ASCII Metadata Filename to Insert (including FULL path)? <path>/<filename>.met
- Hit return to continue or q to quit q

Make Snapshot of the PDPS database

9
Production Monitor/SSI&T Specialist
o Log onto g0pls01

10
Production Monitor/SSI&T Specialist
o Save the database

- cd /usr/ecs/OPS/CUSTOM/utilities

- list_db

- Verify that the name under which to save the database doesn't already exist

- save_db <database name>

- vi README.saved_databases

- Add the name under which you saved the database to the list and follow with a description

Insert the PGE Dynamic Files

11
Production Monitor/SSI&T Specialist
o In the SSIT Manager GUI:

- Select Tools -> Data Server -> Insert Dynamic

- Configuration filename? Hit return for default

- ECS Mode of operations? OPS
- ESDT short name for the file(s) to Insert? MOD01
- ESDT Version for the file(s) to insert? 001
- Is there more than one data file to this Dynamic Granule (Y = Yes, N=No)? N
- Single Filename to Insert (including FULL path)? <full pathname of granule>

- Associated ASCII Metadata Filename to Insert? <filename of .met file>

- Hit return to continue or q to quit Hit return
- Configuration filename? Hit return for default

- ECS Mode of operations? Hit return for default or type: OPS
- ESDT short name for the file(s) to Insert? MOD03
- ESDT Version for the file(s) to insert? 001 

- Is there more than one data file to this Dynamic Granule (Y = Yes, N=No)? N

- Single Filename to Insert (including FULL path)? <full pathname of granule>

- Associated ASCII Metadata Filename to Insert? <filename of .met file>

- Hit return to continue or q to quit q

Create a Production Request

12
Production Monitor/SSI&T Specialist
o Log into DCE on g0pls01

· telnet g0ais01

· login: opsuser

· password: ********

- dce_login opsuser opsuser

- setenv DISPLAY <current terminal>:0.0 (if necessary)

- Verify that all necessary ECS servers are up and running

- cd /usr/ecs/OPS/CUSTOM/utilities

- EcPlPRE_IfStart OPS

- Click on the PR Edit tab

- Click on the PGE button

- In the list box, select MoPGE02, version 1, profile ID 1

- Click on the OK button

- Enter the dates and times for this run (TBD)

- Click on the File menu and select Save As
- Type in the name of the PR in the Selection region: MoPGE02#1#01.<iteration>

- Click on the OK button

- Wait for a pop-up window message: "Production Request Explosion into DPRs ok. 1 DPRs Generated." and click on the OK button

- Close the PR Editor

Bring up Autosys

13
Production Monitor/SSI&T Specialist
o Log onto on g0sps06

· telnet g0sps06

· login: shareusr

password: ********

14
Production Monitor/SSI&T Specialist
o Start Autosys

- setenv ECS_HOME /usr/ecs

- setenv DISPLAY <current terminal>:0.0 (if necessary)

- cd /usr/ecs/OPS/CUSTOM/utilities

- EcDpPrAutosysStart OPS FMR

- Click on the Ops Console button

- In the Ops Console window, uncheck the Freeze Frame button

- Click on the JobScape button in the main Autosys button window



Create the Production Plan and Execute the PGE

15
Production Monitor/SSI&T Specialist
o Log onto on g0pls01

· telnet g0pls01

· login: opsuser

· password: ********

- setenv DISPLAY <current terminal>:0.0 (if necessary)

- cd /usr/ecs/OPS/CUSTOM/utilities

- EcPlSlayAll OPS

- EcPlAllStart OPS 1

- In Planning Workbench, select File -> Save As

- Enter plan name (TBD)

- Click on the OK button

- In the Unscheduled area of window, click on the PGE02 PR to schedule it

- Click on the schedule down arrow

- Click on the Activate button

- In pop-up window, "You need to save current plan before you activate the plan!!!", click on Save

Monitor the PGE Execution in Autosys

16
Production Monitor/SSI&T Specialist
o View the Autosys JobScape window and monitor the job box for the DPR running

17
Production Monitor/SSI&T Specialist
o View the Job Management log file on g0sps06 as the PGE exeuctes:

- cd /usr/ecs/OPS/CUSTOM/logs

- tail -f MoPGE02<DPR ID>.err

18
Production Monitor/SSI&T Specialist
o As each job in the job box completes successfully, it will turn blue

19
Production Monitor/SSI&T Specialist
o When entire job box completes successfully, the entire job box will turn blue

Validate the output products

20
Production Monitor/SSI&T Specialist
o Acquire the output products MOD021KM, MOD02HKM, MOD02QKM and MOD02OBC,

along with the Production History tar file

21
Production Monitor/SSI&T Specialist
o Compare the output with comparison output generated earlier

22
Production Monitor/SSI&T Specialist
o View the Production History tar file
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