ORE-13 OPERATIONS Administration
3.13 ORE-13: Operations Administration
This task exercises: 1) Site Interface Maintenance, 2) Site Startup Confidence and Site Restart,  3) Process Life Cycle, Status and Performance Monitoring, 4) ECS Storage/Archive/Backup Capability, 5) Recovery From Abnormal Non-Catastrophic Shutdown.

Exercise Assumptions:

TBD

ORE Data Sets:

The following Data Sets may be utilized during this ORE:

Data Set Name
Path Name
Description













ORE-13 Procedures:

ORE-13: Step-By-Step Procedures

Step No.
Position
Input Action

Objective 1 – Site Interface Maintenance

1
Ops Controller or Computer Operator
Data Search & Order 

Assumption:  The following servers are up.  Verify, using the ECS Assist Monitor screen or other means: 

on g0acs03, EcDsScienceDataServer,               

on g0dis02,  EcDsDistributionServer,

on g0drg01,  EcDsStStagingDiskServer,

on g0drg01, EcDsStStagingMonitorServer,

on g0drg01, EcDsStArchhiveServer,

on g0drg01, EcDsStFtpDisServer,

on g0acg01, EcDsStPullMonitorServer,

on g0ins02, EcDmEcsToV0Gateway,

on g0ins02, EcDmV0ToEcsGateway,

on g0ins02, EcDmDictServer,

on g0ins02, EcClDtUserProfileGateway,

on g0mss21, EMsAcOrderSrvr.

2
Ops Controller or Computer Operator
· Login to the CLS machine. Start the B0SOT GUI:

· ssh g0ins02

· Enter passphrase

· setenv DISPLAY <Terminal/IP address>:0.0
· xterm –sb –sl 5000 –n “B0SOT GUI” &
· cd /usr/ecs/<MODE>/CUSTOM/bin/CLS
· source runrc_cls
· desktop

3
Ops Controller or Computer Operator
· Log in as instructed and Select B0SOT on the popped up Desktop menu, by double clicking on B0SOT icon.

4
Ops Controller or Computer Operator
· Select User Profile and on the new pop-up screen, fill up user address information (may be fictitious but e-mail address must be correct) and click on save. Repeat for billing and shipping address (convenient to use “copy from user address” feature). Click on close after all three addresses are saved.

5
Ops Controller or Computer Operator
· On the Welcome window, Click on Search Screen.

6
Ops Controller or Computer Operator
Search for the data to be acquired (eg. Aster expedited data): 

· On the Search Screen,
· Click on Inventory. 
· Click on List of Data Center. 

· On the  popped up valids lists  window, highlight ECS-GSFC
· Click Add 

· Click OK.to dismiss valids lists window 

· Click on List of Data Set.

· On the popped up valids lists window, 

· Highlight test data sets. Choose MODIS Level 0 Raw Instrument

· click Add 

· Click OK to dismiss valids lists window

· Click on Geographic Area pull down menu and select Global Search.

· Click on Execute Search.

7
Ops Controller or Computer Operator
Wait until Data is lit up on Communication Status. 

· Click on Data. 

· On the Inventory Results Screen that pops up, 

· Select Screen Function / Turn on Granule Id

· Highlight the test data sets MODIS Level 0 Raw Instrument

· Change order status (column ‘O’) from N to Y by clicking on N

· Click on Order Data

8
Ops Controller or Computer Operator
Order test data. 

· On the Order Data screen, 

· Highlight test data by clicking in Package ID column. 
· Click on Package Options 
· On the popped up Package Options Selection, 
· Select (Click to highlight) Processing Option as Native Granule Size=0 
· Select (Click to highlight) Media Type as FtpPull
· Click on OK to dismiss this pop-up. 
· Click on Submit Order.

9
Ops Controller or Computer Operator
On the Communication Status (Order Data) screen,

· Click on Contact Information. 

· On the Contact Information GUI that pops up, find the Order ID. It is the digits after slash in the ID field almost at the bottom. Copy the Order ID number. 

· Click OK to dismiss the pop-up.

10
Ops Controller or Computer Operator
Close all windows when complete

Order Management using Order Tracking GUI

11
Ops Controller or Computer Operator
Log in to workstation, g0mss21 (preferably as cmshared if it is necessary to execute the next step)and start the User Registration Manager:

· ssh g0mss21

· Enter passphrase
· dce_login <dce login account>

· password: < dce_password>

12
Ops Controller or Computer Operator
Tester: Bring up the ECS Accountability Order Manager server if it is not already running:

· su – cmshared                          (if necessary)
· Enter passphrase

· cd /usr/ecs/<MODE>/CUSTOM/utilities 
· EcMsAcOrderSrvrStart <mode>

13
Ops Controller or Computer Operator
Start ECS Data Order GUI:

· setenv DISPLAY <terminal IP address>
· EcMsAcOrderGUIStart  <MODE>

14
Ops Controller or Computer Operator
Select query by User Name by clicking on the radio button and filling in the Last Name & First Name (that was used in user profile while ordering data) in the edit box

15
Ops Controller or Computer Operator
Select one or more of the following Filter by Status by clicking on the radio buttons (Deselect All or Select All buttons may also be used for convenience): 

Pending                                     Operator Intervention

Staging                                      Transferring 

Not Found                                 Waiting for Shipment 

Shipped                                     Aborted 

Canceled                                    Terminated 

Prep for Distribution                SDSRV Staging

16
Ops Controller or Computer Operator
· Start query by clicking on Query Order and verify the result of the query..

· Select query by Order ID by clicking on the radio button and filling in the Order ID number (that was copied down while ordering data) in the edit box

17
Ops Controller or Computer Operator
Select query by Order ID by clicking on the radio button and filling in the Order ID number (that was copied down while ordering data) in the edit box

18
Ops Controller or Computer Operator
Select one or more of the following Filter by Status by clicking on the radio buttons (Deselect All or Select All buttons may also be used for convenience): 

Pending                                     Operator Intervention

Staging                                      Transferring 

Not Found                                 Waiting for Shipment 

Shipped                                     Aborted 

Canceled                                    Terminated 

Prep for Distribution                SDSRV Staging

19
Ops Controller or Computer Operator
Start query by clicking on Query Order and verify the result of the query.. . 

· Select Delete Order 

· Select Yes in the pop-up box
· To update an order: Select an order from the Order List

· Select Update Order.

· Select Status and/or Description under Items.

· Enter information for status and/or description under New Values.

· Select Update.

20
Ops Controller or Computer Operator
To view shipping information: 

· Select an order from the Order List.

· Select Shipping Information

· Select Close.

21
Ops Controller or Computer Operator
To query a request: Select an order from the Order List.

22
Ops Controller or Computer Operator
To delete a request: 

· Select an order from the Order List.

· Select Delete Request.

· Select Yes in the pop-up box

23
Ops Controller or Computer Operator
To update a request: 

· Select an order from the Order List.

· Select a Request ID for an order in the Request List.

· Select Update Request.

· Select Update.

24
Ops Controller or Computer Operator
Close and exit all windows

TROUBLE TICKET  (TT) PROCEDURES - Submitting Trouble Ticket  by Science User via netscape

25
Ops Controller or Computer Operator
Tester: Log in to g0mss21 and start  netscape

· cd /tools/bin/netscape

· ./netscape &
· type > http://g0msh08.gsfcb.ecs.nasa.gov/MSS/MsTtHTMLMenu?userId=<valid userId>

· Click on Submit a Trouble Ticket.

· Fill out Problem information.

· Select impact of low, medium or high.

· Enter short description of the problem.

· Enter a detailed problem description of the problem.

· Click on “Submit”.

· Select continue submission.

· Verify by calling the DAAC support person to inquire whether they received the email.

26
Ops Controller or Computer Operator
Repeat previous step for different characteristics 

· Submit another ticket for different problem and impact (low, medium, high).

· Click on This Trouble Ticket.

· Click on Trouble Ticket home page icon.

· Click on List my Trouble Tickets
· Click on Trouble Ticket home page icon.

· Exit Netscape

· Check for an email from aruser mail system on trouble ticket submitted.

Check Remedy database for Trouble Tickets Submitted

27
Ops Controller or Computer Operator
GSFC 
· ssh > g0msh08

· Enter passphrase

· setenv DISPLAY <host ip address:0.0>

· cd /usr/ecs/OPS/COTS/remedy/binaruser&

· Select File>Login.

· Type the  Administrator id and Password.

· Click Apply.
· Select File>Open Schema.

· Click on Rel-B Contact Log from the Open Schema window.

· Click on Apply from the Open Schema window.

· Select Trouble Ticket that was created through the ECS Trouble Ticket Web Page

Forward Trouble Ticket  to another DAAC

28
Ops Controller or Computer Operator
· Select  Query > List

· Select  a Trouble Ticket

· Select -> Menu -> Query -> Modify individual

· Change Trouble Ticket to “Forward”

· Go to picklist next to Forward-to field. Verify the delivery of the e-mail.

· Select -> GSF

· Click-> Forward button above Forward-to field

· Click -> APPLY  on the lower left corner. Verify the delivery of the e-mail.

Accept Forwarded Trouble Ticket from another DAAC

29
Ops Controller or Computer Operator
· Select  Query > List

· Double Click on the forwarded Trouble Ticket

Change Trouble Ticket Status to Assigned

30
Ops Controller or Computer Operator
· Select -> Menu -> Query -> Modify individual

· Change Status of Trouble Ticket to “Assigned”

· Check for an email from ARSystem on updated status of trouble ticket submitted via netscape

Change Trouble Ticket status to “Closed”

31
Ops Controller or Computer Operator
· Select -> Menu -> Query -> Modify individual

· Select trouble ticket

· Change Trouble Ticket status to “closed”
· Check for email from ARSystem

Perform Trouble Ticket search using Remedy

32
Ops Controller or Computer Operator
Enter the contact log id in the contact log id field.

· Select query>list.

· Select the contact log from the query-list window.

· Select dismiss from the display window.

· Select dismiss from the query-list window.

33
Ops Controller or Computer Operator
From the Action Request System window,

· Enter the trouble ticket # in the associated TT id field.

· Select query>list.
· Select the contact log from the query-list window.

· Select dismiss from the display window

· Select dismiss from the query-list window.

View Trouble Ticket Schema

34
Ops Controller or Computer Operator
Select File>Open Schema

· Click on Rel-B Contact Log from the Open Schema window

· Click on Apply from the Open Schema window.

· Select Query>List.
· Select a Contact Log.                            

· Query report of Contact Log selected.   From the query list window, select query>report.

Generate report to the screen

35
Ops Controller or Computer Operator
· From the report window, select report to screen… and observe the following:

log id 

log status 

contact method 

associated TT id 

short description 

long description 

comment log 

contact id 

receiving operator 

category 

contact name 

contact phone 

received time 

contact e-mail 

entered time 

contact home DAAC 

modified date 

contact organization 

last modified by 

TT created 

assigned-to 

submitter

ticket status

· Select dismiss.

Generate report in a file

36
Ops Controller or Computer Operator
· From the report window, select report to file…

· Enter directory in directory box.

· Enter directory and file name in selection box.

· Select apply. Inspect the specified directory/file.

Generate report to printer

37
Ops Controller or Computer Operator
· From the report window, select report to printer

· Select a suitable printer from the box displaying available printers.

· Select print. Inspect the printer output.

ASTER Email Gateway - This test is performed at the SMC

38
Ops Controller or Computer Operator
· Select  Query > List

· Select  a Trouble Ticket

· Select -> Menu -> Query -> Modify individual

· Change Trouble Ticket to “Forward”

· Go to picklist next to Forward-to field. Verify the delivery of the e-mail.

· Select -> AGD

· Click-> Forward button above Forward-to field

· Click -> APPLY  on the lower left corner

Forward Trouble Ticket Status to EBNet

39
Ops Controller or Computer Operator
· Select -> Menu -> Query -> Modify individual

· Change Trouble Ticket to “Forward”

· Go to picklist next to Forward-to field
· Select -> Ebnet

· Click-> Forward button above Forward-to field
· Click -> APPLY  on the lower left corner. Verify the delivery of the e-mail.

Forward Trouble Ticket Status to NSI

40
Ops Controller or Computer Operator
· Select -> Menu -> Query -> Modify individual

· Change Trouble Ticket to “Forward”

· Go to picklist next to Forward-to field
· Select -> NSI

· Click-> Forward button above Forward-to field
· Click -> APPLY  on the lower left corner. Verify the delivery of the e-mail.


Submitting a CCR using DDTS

41
Ops Controller or Computer Operator
Log into workstation and execute DDTS.

· ssh g0mss02

· Enter passphrase

· cd /usr/ecs/OPS/COTS/ddts/bin/xddts
· ./xddts
· Click on “Select” from the DDTS main window menu bar and select “Select Project, Class & State” option

· Click on “Change Class” button, and select “Change_Request” class.

· Click OK

· Click on desired project (Example:  “EDFMD_ CCR_HW or EDFMD_ CCR_SW or SMC”).

· Check on states button, select "all", click ok.

42
Ops Controller or Computer Operator
In the next record window, at each prompt enter information based on category.

· Enter a valid entry for each “one of” or multiple entry fields.  Also enter an invalid entry in each of the “one of” or multiple entry fields.

· When complete, the form will return to page 1.  Click on “Commit” button in DDTS main window.

· Check e-mail for incoming DDTS messages.

Management Reports

43
Ops Controller or Computer Operator
· Select -> Metrics -> Management Reports
· Select Class Name -> States <all>

· enter “start date” and “end date”

· Select “Report Selections”

· Select “ Print to Window”
· Select “ Click Ok”

View all the reports printed to screen to make sure it matches search criteria

44
Ops Controller or Computer Operator
Repeat previous steps for each of the listed attributes as necessary:

1. Assigned to Report

2. Average Time to Close

3. Ticket Status by Assigned to

4. Hardware Resource Report

5. Number of Tickets by Priority

6. Software Resource Report

7. Ticket Status Report

Specified report printed to screen to make sure it matches search criteria

Change State

45
Ops Controller or Computer Operator
· Click on “Change_State” from Record windows menu bar, and select “Assign-Eval”.

When complete, the form will return to page 1.  

· Click on “Commit” button in DDTS main window.

· Check e-mail for incoming DDTS messages.

· Select a previously submitted CCR from the DDTS main window listing.

· Click on “Change_State” from Record windows menu bar, and select “Assign-Eval”.

46
Ops Controller or Computer Operator
At each prompt enter information based on category. 

· Enter a valid entry for each of “one of” or multiple entry fields.  Also enter an invalid entry in each of the “one of” and multiple entry fields.

· Click on the “Commit” button in the DDTS main window to store the state transition to the database.

· Check e-mail for incoming messages from DDTS..

· Click on “Change_State” from Record windows menu bar, and select “Assign-Implement”.

47
Ops Controller or Computer Operator
At each prompt enter information based on category.  

· Enter a valid entry for each of “one of” or multiple entry fields.  Also enter an invalid entry in each of the “one of” and multiple entry fields.

· Click on the “Commit” button in the DDTS main window to store the state transition to the database.

· Check e-mail for incoming messages from DDTS..

· Click on “Change_State” from the menu bar on the Record window.  Select “R Implement”.

· Click on the “Commit” button in the DDTS main window to store the state transition to the database.

· Check email for incoming messages from DDTS.

· Click on “Change_State” from the menu bar on the Record window.  Select ‘T Assign-Verify’

· Click on “Change_State” from the menu bar on the Record window.  Select ‘T Assign-Verify’

· Click on “Commit” button in the DDTS main window to store the state transition to the database.

· Check e-mail for incoming messages from DDTS..

· Click on “Change_State” from the menu bar on the Record window.  Select ‘V Verify’

· Enter ‘Test Status’ information.

· At ‘Enclosure Added’ prompt enter Y or N.

· Enter information.

· When complete, click on “File” from the menu bar on the Editor window, and select “Save Changes & Dismiss Editor”.

· Enter the name of the enclosure and click on “OK”.

· Click on “Commit” button in the DDTS main window to store the state transition to the database.

Check e-mail for incoming messages from DDTS.

Network Utilization Report from NSI

48
Ops Controller or Computer Operator
· ssh  g0msh08
· Enter passphrase 
· setenv DISPLAY <host ip address:0.0>
· cd /tools/bin/netscape

·  netscape &
Open internet browser for Periodic utilization report from NSI home page by entering URL: 

· type > http://www.nsi.com/report
· Click on hyperlink to download the periodic network utilization report.

· Click “OK”. Inspect the specified directory/file.

Network Utilization Report from EBNet

49
Ops Controller or Computer Operator
Open internet browser for Periodic utilization report from EBNet home page by entering URL: 

· type > http://www.ebnet.com/report
· Click on hyperlink to download the periodic network utilization report.

· Click “OK”
OR ftp

· Click “OK”. Inspect the specified directory/file.

Network Topology Map from EBNet

50
Ops Controller or Computer Operator
Open internet browser for Network Topology Map from EBNet home page by entering URL: 

· type > http://www.ebnet.com/map
· Click on hyperlink to download the periodic topology map report.

· Click “OK”. Inspect the specified directory/file.

ORE-13: Step-By-Step Procedures

Step No.

Input Action

Objective 2 – Site Startup Confidence and Site Report

1
Ops Controller or Computer Operator
Verify that no servers are running. If necessary logon to all ECS machines (see attachment)  to ensure that the servers are down by entering the following command:

· ssh <machine name>

· Enter passphrase

2
Ops Controller or Computer Operator
Log in to the MSS server g0msh08 as cmshared, and setup the HPOV GUI environment as follows. :
· ssh g0msh08

· Enter passphrase
· setenv DISPLAY <host name>:0.0

· source  /home/cmshared/ov_env.csh

3
Ops Controller or Computer Operator
Check if Ecsd is running. If not, start it. 

· /bin/ps -ef | grep Ecsd  (if running,  pid will be returned)
· /usr/ecs/SHARED/CUSTOM/utilities/EcMsEcsdStart SHARED(only if Ecsd is not running)

4
Ops Controller or Computer Operator
Check if Deputy is running. If not, start it.

· /bin/ps -ef | grep Deputy (if running, the pid will be returned)
· /usr/ecs/SHARED/CUSTOM/utilities/EcMsAgDeputyStart SHARED  (only if Deputy is not running)

5
Ops Controller or Computer Operator
Check if SubAgent is running on all the ECS machines. Invoke an xterm window and log in to an ECS (e.g. g0mss21) as cmshared.
· ssh

· Enter passphrase 

· ps –ef | grep MSS (if running, the pid will be returned)
· usr/ecs/SHARED/CUSTOM/utilities/EcMsAgStartSubAgent SHARED           (only if Subagent is not running)

6
Ops Controller or Computer Operator
Repeat the above step for all ECS machines. (It is not necessary to open a new xterm window for every machine, start from telnet). Machine-Subagent list: g0ins01, g0ins02, g0drg01, g0dis02,g0acs03, g0icg01, g0acg01, g0wkg01, g0mss21,  g0pls02 and g0sps06

7
Ops Controller or Computer Operator
Invoke HP OpenView GUI. On g0msh08:

/opt/OV/bin/ovw -map Operations

Bring up / Bring down of MSS servers at the application, program, and process levels

8
Ops Controller or Computer Operator
Invoke the Quick Navigator window. On the Root Window:

· Click on Locate -> Quick Access -> Quick Navigator
Open g0mss21 window. 

· Double Click on g0mss21 icon.
Start the Executables:

· Click right button on EcMsAccountabilityApp -_1_TS2  (wheat color icon)
· Select Start Executable (from pull down menu)
Shutdown the Executables:

· Click right button on EcMsAccountabilityApp_<dddd>_TS2  (green color icon)
· Select Shutdown Executable (from pull down menu)
Verify that the executables are not running. On a g0mss21 terminal, 

· ps –ef |    grep TS2
Start individual servers in the TS2 mode at a program level: On g0mss21 window,

· Double click on EcMsAccountabilityApp_-1_TS2 (wheat color icon)


9
Ops Controller or Computer Operator
Start an individual server (e.g. EcMsAcRegUserSrvr). On the dddddd.g0mss21.<site address>_TS2 window,

· Click right button on EcMsAcRegUserSrvr (wheat color icon)
· Select Start Executable  (from pull down menu)
Start another server (e.g. EcMsAcRegUserSrvr). On the dddddd.g0mss21<site address>-1_TS2 window,

· Click right button on EcMsAcOrderSrvr (wheat color icon)
· Select Start Executable  (from pull down menu)
· close the dddddd.g0mss21<site address>-1_TS2 window

10
Ops Controller or Computer Operator
Stop individual servers in the TS2 mode at a program and process level: On g0mss21 window,

· Double click on EcMsAccountabilityApp_-1_TS2 (green color icon)
Stop an individual server (e.g. EcMsAcRegUserSrvr) at program level. On the dddddd.g0mss21<site address>-1_TS2 window,

· Click right button on EcMsAcRegUserSrvr (green color icon)
· Select Shutdown Executable  (from pull down menu)
Stop an individual server (e.g. EcMsAcOrderSrvr) at process level. On the dddddd.g0mss21<site address>-1_TS2 window,

· Double click on EcMsAcOrderSrvr (green color icon)
· Click right button on <the process id>
Select Shutdown Executable  (from pull down menu)

Bring the following servers in TS2 mode

11
Ops Controller or Computer Operator
Start all servers in the TS2 mode: 

· Go to Root sub map  
· Double click on the Service icon 
· Double-click on the Mode icon (on the newly invoked service window)
· Double-click on the TS2 icon in Mode window

12
Ops Controller or Computer Operator
Start Servers of MSS subsystem:

· RIGHT Click on “EcMsAccountabilityApp_-1_g0mss21”  in wheat color and select

· “Start Executable” for the following servers: EcMsAcOrderSrvr on g0mss21 EcMsAcRegUserSrvr on g0mss21

13
Ops Controller or Computer Operator
Shutdown Servers of MSS subsystem:

Go to TS2 window 

· RIGHT Click on “EcMsAccountabilityApp_-1_g0mss21” in green color and select

· “Shutdown Executable” for the following servers: EcMsAcOrderSrvr on g0mss21 EcMsAcRegUserSrvr on g0mss21

14
Ops Controller or Computer Operator
Start Servers of DPS subsystem:

· RIGHT Click on “EcDpProcessingApp_-1_g0sps06…” in wheat color and select 

· “Start Executable” for each of the following servers: EcDpPrDeletion on g0sps06 EcDpPrJobMgmt on g0sps06

15
Ops Controller or Computer Operator
Shutdown Servers of DPS subsystems:

· RIGHT Click on “EcDpProcessingApp_-1_g0sps06…” in green color and select

· “Shutdown Executable” for each of the following servers: EcDpPrDeletion on g0sps06 EcDpPrJobMgmt on g0sps06

16
Ops Controller or Computer Operator
Start Server of Planning Subsystem (PLS):

· RIGHT Click on “EcPIPlanningApp_-1_g0pls02…”  in wheat color and select

· “Start Executable” for the following server: EcPlSubMgr on g0pls02

17
Ops Controller or Computer Operator
Shutdown Server of Planning Subsystem (PLS):

· RIGHT Click on “EcPIPlanningApp_-1_g0pls02…” in green color and select 

· “Shutdown Executable” for the following server:EcPlSubMgr on g0pls02

18
Ops Controller or Computer Operator
Start Servers of SDSRV Subsystem:

· RIGHT Click on “EcDsScienceDataServerApp - 1_g0acs03…” in wheat color and select

· “Start Executable” for each of the following servers: EcDsHdfEosServer on g0acs03 EcDsScienceDataServer on g0acs03

19
Ops Controller or Computer Operator
Shutdown Servers of SDSRV Subsystem:

· RIGHT Click on “EcDsScienceDataServerApp_-1_g0acs03…” in green color and select

· “Shutdown Executable” for each of the following servers: EcDsHdfEosServer on g0acs03, EcDsScienceDataServer on g0acs03

20
Ops Controller or Computer Operator
Start Ingest  (INS) subsystem:

· RIGHT Click on “EcDsStStoragemgmtApp_-1_g0acg01…” in wheat color and select “Start Executable” for each of the following servers: EcDsStIngestftpServer on g0acg01, EcDsStStagingMonitorServer on g0acg01, EcDsStStagingDiskServer on g0acg01, EcDsStPullMonitorServer on g0acg01, EcDsStArchiveServer on g0acg01

21
Ops Controller or Computer Operator
shutdown Ingest  (INS) subsystem:

· RIGHT Click on “EcDsStStoragemgmtApp_-1_g0acg01…” in green color and select “Shutdown Executable” for each of the following servers: EcDsStIngestftpServer on g0acg01, EcDsStStagingMonitorServer on g0acg01, EcDsStStagingDiskServer on g0acg01, EcDsStPullMonitorServer on g0acg01, EcDsStArchiveServer on g0acg01

22
Ops Controller or Computer Operator
Start Data Server (DSS) subsystem:

· RIGHT Click on “EcDsStStorageMgmtApp_-1_g0dis02…” in wheat color and select “Start Executable” for each of the following servers:EcDsSt4MMServer on g0dis02, EcDsSt8MMServer on g0dis02, EcCdStCDROMServer on g0dis02, EcDsStD3Server on g0dis02, EcDsStPrintServer on g0dis02

23
Ops Controller or Computer Operator
Shutdown Data Server (DSS) subsystem:

· RIGHT Click on “EcDsStStorageMgmtApp_-1_g0dis02…” in green color and select “Shutdown Executable” for each of the following servers: EcDsSt4MMServer on g0dis02, EcDsSt8MMServer on g0dis02, EcCdStCDROMServer on g0dis02, EcDsStD3Server on g0dis02, EcDsStPrintServer on g0dis02

24
Ops Controller or Computer Operator
Start Storage Management Server (STMGT) subsystem:

· RIGHT Click on “EcDsStStorageMgmtApp_-1_g0drg01…” in wheat color and select “Start Executable” for each of the following servers: EcDsStPullMonitorServer on g0drg01, EcDsStStagingDiskServer on g0drg01, EcDsStFtpDisServer on g0drg01, EcDsStArchiveServer on g0drg01

25
Ops Controller or Computer Operator
Shutdown Storage Management (STMGT) subsystem:

· RIGHT Click on “EcDsStStoragemgmtApp_-1_ g0drg01…” in green color and select “Shutdown Executable” EcDsStPullMonitorServer on g0drg01, EcDsStStagingDiskServer on g0drg01, EcDsStFtpDisServer on g0drg01, EcDsStArchiveServer on g0drg01

26
Ops Controller or Computer Operator
Start Client (CLS) subsystem:

· RIGHT Click on “EcCIDtUserProfileGatewayApp_-1_g0ins02…” in wheat color and select  “Start Executable” EcCIDtUserProfileGateway on g0ins02

27
Ops Controller or Computer Operator
Shutdown Client (CLS) subsystem:

· RIGHT Click on “EcCIDtUserProfileGatewayApp_-1_ g0ins02…”  in green color and select “Shutdown Executable”

28
Ops Controller or Computer Operator
Start Server of IOS subsystem:

· RIGHT Click on “EcIoAdvertisingApp_-1_ g0ins02…”  in wheat color and select “Start Executable”  to bring up the following server: EcIoAdServer on g0ins02

29
Ops Controller or Computer Operator
Shutdown Server of IOS subsystem:

· RIGHT Click on “EcIoAdvertisingApp_-1_ g0ins02…” in green color and select “Shutdown Executable” EcIoAdServer on g0ins02

30
Ops Controller or Computer Operator
Start Servers on Data Dictionary (DDICT) subsystem:

· RIGHT Click on “EcDmDataDirectoryApp_-1_ g0ins02…” in wheat color and select “Start Executable” EcDmDictServer on g0ins02

31
Ops Controller or Computer Operator
Shutdown Servers on Data Dictionary (DDICT) subsystem:

· RIGHT Click on “EcDmDataDictionaryApp_-1_ g0ins02…” in green color and select “Shutdown Executable” EcDmDictServer on g0ins02

32
Ops Controller or Computer Operator
Start Servers of Data Management Subsystem (DMS):

· RIGHT Click on “EcDmV0GatewayApp_-1_ g0ins02…” in wheat color and select “Start Executable”  to bring up the following server EcDmV0ToEcsGateway on g0ins02 EcDmEcsTo V0Gateway on g0ins02

33
Ops Controller or Computer Operator
Shutdown Servers of Data Management Subsystem (DMS):

· RIGHT Click on “EcDmV0GatewayApp_-1_ g0ins02…” in EcDmV0ToEcsGateway on g0ins02 green color and select “Stop Executable”  to shutdown the following server(s): EcDmV0ToEcsGateway on g0ins02, EcDmEcsTo V0Gateway on g0ins02

34
Ops Controller or Computer Operator
Start Servers of Data Management Subsystem (DMS):

· RIGHT Click on “EcDmDimLimApp_-1_ g0ins02…” in wheat color and select “Start Executable” to bring up the following server(s): EcDmLimServer on g0ins02

35
Ops Controller or Computer Operator
Shut down server of Data Management subsystem (DMS):

· RIGHT Click on “EcDmDimLimApp –1 g0ins02. . .: in green color and select “Shutdown Executable” EcDmLimServer on g0ins02

36
Ops Controller or Computer Operator
Start Data Distribution (DDIST) subsystem:

· RIGHT Click on “EcDsDataDistributionApp_-1_g0dis02…” in wheat color and select “Start Executable” EcDsDistributionServer on g0dis02

37
Ops Controller or Computer Operator
Shutdown Data Distribution (DDIST) subsystem:

Right Click on “EcDataDistributionApp_-1_g0dis02…” in green color and select “Shutdown Executable” for the following server: EcDsDistributionServer on g0dis02

38
Ops Controller or Computer Operator
RIGHT Click on “EcCsEmailParserApp_-1_g0ins01…”  in wheat color and select “Start Executable” to bring up the following server: EcCsEMailParser on g0ins02

39
Ops Controller or Computer Operator
· RIGHT Click on “EcCsEmailParserApp_-1_g0ins01…”  in green color and select “Shutdown Executable” 

40
Ops Controller or Computer Operator
Start Servers of IDG:

· RIGHT Click on “EcSbSubServerApp_-1_g0ins01…” in wheat color and select “Start Executable” for the following server: EcSbSubServer on g0ins01

41
Ops Controller or Computer Operator
Shutdown Server of IDG:

· RIGHT Click on “EcSbSubServerApp_-1_g0ins01…” in green color and select “Shutdown Executable” for the following server: EcSbSubServer on g0ins01

42
Ops Controller or Computer Operator
Start Servers of Ingest (INS) subsystem:

· RIGHT Click on “EcInIngestApp_-1_g0icg01…”  in wheat color and select “Start Executable” for the following server: EcInAuto on g0icg01, EcInReqMgr on g0icg01, EcInGran on g0icg01

43
Ops Controller or Computer Operator
Shutdown Ingest (INS) subsystem:

· RIGHT Click on “EcInIngestApp_-1_ g0icg01…” in green color and select “Shutdown Executable” for the following server: EcInAuto on g0icg01, EcInReqMgr on g0icg01, EcInGran on g0icg01

44
Ops Controller or Computer Operator
Shutdown Ingest (INS) subsystem:

· RIGHT Click on “EcInIngestApp_-1_ g0icg01…” in green color and select “Shutdown Executable” for the following server: EcInAuto on g0icg01, EcInReqMgr on g0icg01, EcInGran on g0icg01

45
Ops Controller or Computer Operator
Bring up the following servers in TS1 mode

46
Ops Controller or Computer Operator
Bring up all servers in TS1 mode by clicking the right button and then selecting Start Executable option on each of the following 

EcInIngestApp_-1_ g0icg01

EcSbSubServerApp_-1_g0ins01

EcCsEmailParserApp_-1_g0ins01

EcDsDataDistributionApp_-1_g0dis02

EcDmDimLimApp –1 g0ins02.

EcDmV0GatewayApp_-1_ g0ins02

EcDmDataDirectoryApp_-1_ g0ins02

EcIoAdvertisingApp_-1_ g0ins02

EcCIDtUserProfileGatewayApp_-1_ g0ins02

EcDsStStoragemgmtApp_-1_g0acg01

EcDsStStorageMgmtApp_-1_g0dis02

EcDsStStoragemgmtApp_-1_ g0drg01

EcDsStStorageMgmtApp_-1_g0dis02

EcDsStStoragemgmtApp_-1_g0acg01

EcDsScienceDataServerApp - 1_g0acs03

EcPIPlanningApp_-1_g0pls02

· EcMsAccountabilityApp_-1_g0mss21

47
Ops Controller or Computer Operator
· Bring up all above servers in TS2 mode

· Bring up all above servers in OPS mode and simultaneously bring down the above servers in TS1 mode while servers in TS2 and OPS are up.

48
Ops Controller or Computer Operator
On g0mss21, kill the EcMsAgSubAgent as follows:

· ps -ef | grep SubAgent

· Kill -9 <Process identification>

49
Ops Controller or Computer Operator
Shutdown the following server of the MSS subsystem TS2 as follows:

· RIGHT Click on “EcMsAccoutnabilityApp_-1_g0mss21” and select “Shut Executable” for the following servers: EcMsAcOrderSrvr on g0mss21, EcMsAcRegUserSrvr on g0mss21

(Note:  This step will fail due to the previous step which kills subagent.

50
Ops Controller or Computer Operator
Bring the EcMsAgSubAgent up on g0mss21as follows:

· cd /usr/ecs/SHARED/CUSTOM/utilities/

· ls

· EcMsAgSubAgentStart SHARED

· Ps –ef  | grep SubAgent

51
Ops Controller or Computer Operator
Shutdown the following server of the MSS subsystem in TS2 as follows:

· RIGHT Click on “EcMsAccoutabilityApp_-1_g0mss21” and select “Shutdown Executable” 

52
Ops Controller or Computer Operator
On g0mss21, login as su -cmts2 <password>

· cd  /usr/ecs/TS2/custom/utilities

· vi EcMsAcRegUserSrvrStart  

· and comment out  the following lines: SUBSYS=MSS, COMPONENT=EcMsAc, EXECUTABLE=EcMsAcUserSrvr

53
Ops Controller or Computer Operator
Bring up the following server of the MSS subsystem in TS2 as follows:

· Right Click on “EcMsAccountabilityApp_-1_g0mss21” and select “Start Executable” 

Go to the g0mss21 and do:

· ps –ef  | grep TS2 EcMsAcRegUserSrvr on g0mss21

54
Ops Controller or Computer Operator
vi /usr/ecs/TS2/CUSTOM/utilities/ EcMsAcRegUserSrvrStart and take out comments from those three lines as follows: SUBSYS=MSS, COMPONENT=, EXECUTABLE=EcMsAcRegUserSrvr

55
Ops Controller or Computer Operator
Bring up  the following server of MSS subsystem on g0mss21: EcMsAcRegUserSrvr

56
Ops Controller or Computer Operator
Ask operator to shut down the mode on  the g0mss21 machine.

57
Ops Controller or Computer Operator
Ask operator to turn ON the g0mss21 machine.

58
Ops Controller or Computer Operator
Bring up all servers on g0mss21 in all modes --- the following servers will come up in all modes:

EcMsAcOrderSrvr on g0mss21

59
Ops Controller or Computer Operator
Bring up all servers on g0mss21 in all modes --- the following servers will come up in all modes:

EcMsAcOrderSrvr on g0mss21

60
Ops Controller or Computer Operator
Finish the test gracefully:

61
Ops Controller or Computer Operator
Close all GUI windows

62
Ops Controller or Computer Operator
Log out from all terminals windows

ORE-13: Step-By-Step Procedures


Step No.
Input Action

Objective  – 3 Process Life Cycle, Status and Performance Monitoring

Precondition:

1
Ops Controller or Computer Operator
On HPOV map check IP Internet map to verify that all machines are represented with an icon. Machines running SNMP Agent are represented by a green icon.

· To monitor Performance and Fault for Ingest, Processing and Distribution, this test should be conducted concurrently with the following processes: when adding ESDTs, FTP Push of data, FTP Pull of data and ingesting data via the DSS Request Driver.

· When registering and running PGEs.  Note: Per ESDIS personnel, all common error conditions need not to be tested at all sites. As a result, this pre-condition will be waived for EDC and LaRC sites.

HPOV

2
Ops Controller or Computer Operator
Log in to g0msh08 machine:

· ssh  g0msh08

· Enter passphrase

Setup the HPOV GUI environment. 

· xhost + 198.118.210.63 on x-term window you logged on.

· source /opt/OV/bin/ov.envvars.csh

· setenv DISPLAY <host name>:0.0

3
Ops Controller or Computer Operator
· Double Click on IP internet map to verify the status of the machines monitored by HPOV

Inspect the Events on the event Categories  Window

· Click on Events Category button

Close the fault browser window:

· double click on “ – “on upper left corner (title bar) of the fault browser window

Inspection of PDPS when PGE are being run and Ingest machines while they are ingesting data. 

· Click on Performance Event and look for messages pertaining to g0sps06 and g0icg01

Check Debug log on g0sps06 and g0icg01 to verify that the debug log corresponds with HPOV status.

· ssh g0sps06

· Enter passphrase

· cd /usr/ecs/<MODE>/CUSTOM/logs
· type >more EcDpPrJobMgmtDebug.log

4
Ops Controller or Computer Operator
Check Debug log on g0icg01 to verify that the debug log corresponds with HPOV status.

· ssh g0icg01

· Enter passphrase

· cd /usr/ecs/<MODE>/CUSTOM/logs

· type > more EcInGranDebug.log

Inspect the application performance: On the event Categories  Window, 

· Click on ECS Application Performance Events button
Close the performance browser window:

· double click on “ – “ on upper left corner (title bar) of the performance browser window

Network Performance

5
Ops Controller or Computer Operator
From the IP Internet Map, 

· select Options> Data Collection & Thresholds: SNMP
· Select a Disk% util MIB object.

· Select the MIB object Collection Summary Information in the MIB Object Collection Summary box by double clicking on it.

· Set the collection mode to Store, Check Thresholds by clicking on the button and highlighting this option.

· Change threshold value of Disk% util rearm value from >50 to < 20 .

· Change the default polling interval to a smaller interval. 

· Select OK.

From the Data Collection & Thresholds: SNMP window, 

· select File>Save.

6
Ops Controller or Computer Operator
From the Event Categories window, 

· select Threshold Events by clicking once.

Verify that Messages about “threshold change” for a <MIB object> when the threshold changes are made

· Check Threshold Event and Messages throughout the test….if it change to any color, click on the button to browse the threshold messages

· ssh g0mss21
· Enter passphrase

7
Ops Controller or Computer Operator
Check to see if Peer Master Agent is running

· ps –ef | grep EcMsAgAgent 
If not start the Peer Agent (Master Agent) as follows:

· /usr/ecs/SHARED/CUSTOM/utilities/EcMsAgPeerStart  SHARED

8
Ops Controller or Computer Operator
On the root window, 

· Click on Locate (Quick Access (Quick Navigator
On the Quick Navigator root window, 

· Click on g0mss21 icon

On the Quick Navigator window, 

· Click on g0mss21 icon

On g0mss21 window, 

· Click on Misc( ECS MIB Browser

9
Ops Controller or Computer Operator
Fill in the necessary information. Type in as follows:

Community Field :  eosDis
· Mode:  <MODE>
· IP Address for g0mss21

· Select on MSS
· Click on “down tree” twice

· Select Process
· Click on “down tree”

· Select procPerf Table 

· Click twice on “down tree”

10
Ops Controller or Computer Operator
Observe performance

· Select procPerfType 

· Click on “Start Query”

11
Ops Controller or Computer Operator
Observe performance :

· Highlight procPerfvalue 
· Click on Start Query
· Highlight procPerMaxThreshold 
· Click on Start Query

12
Ops Controller or Computer Operator
Exit from MIB browser:

· Select File/Close

Interface Statistics via HPOV

13
Ops Controller or Computer Operator
At the root window, 

· double click on IP Internet

· Click on g0msh08 icon and go to menu and 

· Click on Performance (Network Activity ( Interface Statistics

14
Ops Controller or Computer Operator
On Interface Statistics window,

· Select View ( Change Selection
On the Interface Statistics window,

· Click Restart
On Interface Statistics window,

· Click Close
On Root window ,

· Select  Performance (Interface Traffic
On Interface Traffic window,

· Click Close
On Root window,

· Select on Performance (CPU Load
On CPU Load window, 

· Click Close
On Root window,

· Select  Performance (Network PollingStatistics
On Network Polling window,

· Click Close

Hardware Faults - Detection of powered down hardware

15
Ops Controller or Computer Operator
At the Root window,

· click on IP Internet icon

At the IP Internet window,

· Double Click on 198.118.210 icon

At the IP Map window, 

· Double click on Segment 1 icon

Turn off the Printer g0msh09

Turn on the Printer g0msh09

Graceful Shutdown

16
Ops Controller or Computer Operator
· Click on Close to close all windows 

· Click on Exit to exit from HP Open View

ORE-13: Step-By-Step Procedures


Step No.
Input Action

Objective  – 4: ECS/Storage/Archive/Backup Capability

ARCHIVE  BACKUP

Note: There are steps in this test that requires  amass System Administrator priviledge 

Identify archive and backup directories

1
Ops Controller or Computer Operator
Logon to the Science Data Server machine, g0acs03 and get an x-terminal with large number of scroll lines:
· ssh <machine name>

· Enter passphrase 

· setenv DISPLAY <terminal IP address>:0.0    

· xterm -sb -sl 4444  -n SQL &

2
Ops Controller or Computer Operator
View library containing volume group on g0acs03 

( cd /usr/ecs/<MODE>/CUSTOM/utilities

( setenv MODE <MODE>

( setenv DSQUERY g0acg01_srvr

( source EcCoEnvCsh

( isql -Uanonymous -Sg0acg01_srvr

( use EcDsScienceDataServer1_<MODE> 

(Do not use mode suffix, _<mode> in OPS mode)
( go

( select configuredName, archiveIdentifier, backupIdentifier from DsGeESDTConfiguredType 

(may optionally be followed by where backupIdentifier  != “<13 spaces>“, to cut down the query output)

( go

Select a configuredName which has both archiveIdentifier and backupIdentifier, e.g. AST_EXP.

3
Ops Controller or Computer Operator
Start the Storage Management GUI. Log in to distri​bution server g0dis02,  get an x-terminal and invoke GUI:

· ssh: <machine name>

· Enter passphrase
· xterm  -sb -sl 4444  &

· cd /usr/ecs/<MODE>/CUSTOM/utilities

· setenv DISPLAY <terminal IP address>:0.0

· setenv MODE <mode>

· EcDsStmgtGuiStart <MODE>

4
Ops Controller or Computer Operator
In the Storage Management GUI, type the following commands:

(   Click on  Storage Config.

· Double click on Archive.

5
Ops Controller or Computer Operator
Select the Volume Group as obtained in the database search (for archive and backup identifier) by clicking on it.

· Click on View Volume Group Information at the bottom of the screen.

· Click on Close to exit out of the Volume Group Information screen.

· Select File ( Exit

Archiving by Ingest

Assumption:  The INGEST related servers are up.  Verify using the ECS Assist Monitor screen (on g0icg01) or other means that the following servers are running:

EcInAuto, EcInReqMgr, EcInPolling.FDD, EcInPolling.EDOS, EcInPolling.IAS, EcInPolling.NCEP, EcInPolling.SCF, EcInGran.

Note:  At the start of the test, ingest client machine (g0icg01) polling directory, /usr/ecs/<mode>/CUSTOM/icl/a/ data/pollEDOS must not contain the EDR and signal files (eg. AST_EXP.EDR and AST_EXP.EDR.XFR). If needed, delete them from the polling directory.

6
Ops Controller or Computer Operator
Log into a Ingest Client machine, g0acs02 as cmshared, and open the ingest GUI:

· ssh <machine name>

· Enter passphrase 
· xterm –sb –sl 5000 –n “IngestGUI” &
· setenv DISPLAY <Terminal/IP address>:0.0
· cd /usr/ecs/<MODE>/CUSTOM/utilities
· setenv MODE <mode>
· EcInGUIStart <mode>

7
Ops Controller or Computer Operator
On theINGEST GUI,  select the “Operator Tools” function..On the “Operator Tools” screen, perform the following selections:

· enter EDOS as the External Data Provider

· set the priority to Low
· click the OK button

8
Ops Controller or Computer Operator
· On the INGEST GUI select the “Monitor/Control” function.

9
Ops Controller or Computer Operator
On the “Monitor/Control” screen, perform the following steps/commands:

· select Search By: Data Provider
· enter EDOS
· select Text View
Note:  Disregard repetitive pop-up windows. An NCR has already been generated. The current work around is to move the message window to a corner of the screen.

10
Ops Controller or Computer Operator
Log into a Ingest Client machine, g0acs02 and check the polling directory and data.

· ssh <machine name>

· Enter passphrase 

· xterm –sb –sl 5000 –n “Polling” &
· cd /usr/ecs/<MODE>/CUSTOM/icl/a/data
· cd pollEDOS/pdrs
· ls –al
· sum <filename>    (for data and metadata)

11
Ops Controller or Computer Operator
Print the directory listing: In a Sun machine terminal,  

( setenv DISPLAY <terminal ID>:0.0
( xdpr -d<printer name>

( move the cross-bow to the directory listing widow

( press the left mouse button

(wait for 2 beeps before going back to the terminal window)

Note: This step initiates the actual ingest operation. But, it will result in a new ingest only if the polling directory did not have these  files already (initiating an earlier ingest).

12
Ops Controller or Computer Operator
On the Polling Directory window xterm copy the EDR and signal files from directory /usr/ecs/<MODE>/CUSTOM/icl/a/data/pollEDOS/pdrs  to /usr/ecs/<MODE>/CUSTOM/icl/a/data/pollEDOS:

(The files must be corresponding to the data selected in step 30, i.e. the data has a backupIdentifier; so the ingested data will go to primary as well as backup archive)

cp AST_EXP.EDR*   . .      (for example. Note that the copied files AST_EXP.EDR*  contain information regarding the data and metadata files to be archived, so the copied files themselves are not archived. )

13
Ops Controller or Computer Operator
Review the Monitor/Control display. Note the Request ID displayed on the screen.

Inspect the Ingest GUI Monitor/Control Screen

· From the Ingest GUI, click on “History Log” icon.

14
Ops Controller or Computer Operator
Enter the following on the “History Log” screen:

· start time and date
· data provider = EDOS  (NOTE:  to select “EDOS” from the pull-down menu, you must click the mouse outside of the menu in order for the selection to appear on the screen; this problem has previously been noted)

· select detailed report
· select display

15
Ops Controller or Computer Operator
(Optional) Obtain Granule information. In history log display box, 

· Double click on the line displaying ingest status 

· Inspect the message poped up for Granule_List 
· Click  on Go Back    (after inspecting the message)

Inspect Primary and Backup Archive Data

16
Ops Controller or Computer Operator
Query the Science Data Server Inventory database to verify the ingested data granules are archived. At the SQL window, at SQL command prompt:   (AST_EXP is used as an example): 

· use EcDsScienceDataServer1_<mode> 
(Do not use mode suffix, _<mode> in OPS mode)

· go
· select * from DsMdGranules where ShortName = “AST_EXP”
· go

17
Ops Controller or Computer Operator
Logon to the Archive Server machine g0drg01, get an x-terminal with large number of scroll lines:
· ssh <machine name>

· Enter passphrase 

· xterm -sb -sl 4444  -n “ArchiveServer”&
· cd <primary archive path>
· ls -altr  
· sum <filename>                    (for data and metadata)

Verify the file time stamps and file sizes correspond to the ingested data set.

18
Ops Controller or Computer Operator
Print the directory listing: In a Sun machine terminal,  

( setenv DISPLAY <terminal ID>:0.0
( xdpr -d<printer name>

( move the cross-bow to the directory listing widow

( press the left mouse button

(wait for 2 beeps before going back to the terminal window)

19
Ops Controller or Computer Operator
Obtain a listing of the archive backup cache directory.  On the Archive Server window:

· cd <backup path>
· ls -altr  
· sum <filename>                       (for data and metadata)

Verify the file time stamps and file sizes correspond to the ingested data set.

20
Ops Controller or Computer Operator
Print the directory listing: In a Sun machine terminal,  

( setenv DISPLAY <terminal ID>:0.0
( xdpr -d<printer name>

( move the cross-bow to the directory listing widow

( press the left mouse button

(wait for 2 beeps before going back to the terminal window)

Corrupt the data on the primary copy

21
Ops Controller or Computer Operator
Verify completion of data copying onto the Tape. On the ArchiveServer window,

( cd /usr/amass/bin

( sysperf -c -k 5
Look for the line containing CACHE BLOCKS.

Note:  <Control C> will terminate the task.

22
Ops Controller or Computer Operator
Determine the volume group and physical volume number (not same as logical volume group number obtained in step 160) of  the archive tape to be corrupted. Then determine a file that will be corrupted: On the Archive Server window (t1drg01),

· cd /usr/amass/bin

· ./dirfilelist –hv <primary path> | grep <part file name>

Note the volume & logical start block numbers (the first & second decimal number after file name). The start block number will be the offset used later.

23
Ops Controller or Computer Operator
Get the volume label from the volume number obtained in the last step. 

· ./vollist <volume number> 

Note the “volume label” (e.g. SD0004).

24
Ops Controller or Computer Operator
Get tape drive information to formulate later command

· hinv | grep SD3
Study the response that will look like:

Tape drive: unit 1 on SCSI controller 2: STK SD3
Note the controller and drive number. The device would then be  /dev/rmt/tps<controller #>d<unit #>. For the example above, it is:  /dev/rmt/tps2d1

Select a tape drive, preferably one not being used. It will be referred to as drive #  in subsequent steps

25
Ops Controller or Computer Operator
Take the selected drive off-line and put the tape (to be corrupted) on the drive..

· drivestat  –i  <drive #>

· /usr/amass/utils/mediamove V<volume label>  <drive #>  0
Note that the V is prefixed to the volume label such as VSD0004. This command moves the tape from its home slot in the juke box to the tape drive (drive #).

26
Ops Controller or Computer Operator
Move the media back to the juke box and put the drive online.

· mediamove  <drive #> V<volume label>  0
· drivestat  –a  <drive #>

Acquire from Backup

Assumption:  The following servers are up.  Verify, using the ECS Assist Monitor screen or other means: 

On g0acs03, EcDsScienceDataServer,  on g0dis02,  EcDsDistributionServer, on g0drg01,  EcDsStStagingDiskServer, on g0drg01, EcDsStStagingMonitorServer, on g0drg01, EcDsStArchhiveServer, on g0drg01, EcDsStFtpDisServer, on g0acg01, EcDsStPullMonitorServer, on g0ins02, EcDmEcsToV0Gateway, on g0ins02, EcDmV0ToEcsGateway, on g0ins02, EcDmDictServer, on g0ins02, EcClDtUserProfileGateway, on g0mss21, EmsAcOrderSrvr.

27
Ops Controller or Computer Operator
Login to the Ingest machine, g0ins02. Open Z-mail and start the B0SOT GUI:

· ssh <machine name>

· Enter passphrase 

· setenv DISPLAY <Terminal/IP address>:0.0
· xterm –sb –sl 5000 –n “B0SOT GUI” &
· cd /usr/ecs/<MODE>/CUSTOM/bin/CLS
· zm &
· source runrc_cls
· desktop

28
Ops Controller or Computer Operator
Log in as instructed and Select  B0SOT on the popped up Desktop menu, by double clicking on B0SOT icon.

29
Ops Controller or Computer Operator
Select User Profile and on the new pop-up screen, fill up user address information (may be fictitious but e-mail address must be correct) and click on save. Repeat for billing and shipping address (convenient to use “copy from user address” feature). Click on close after all three addresses are saved.

30
Ops Controller or Computer Operator
On the Welcome window, Click on Search Screen.

31
Ops Controller or Computer Operator
Search for the data to be acquired (eg. Aster expedited data): On the Search Screen,
· Click on Inventory. 
· Click on List of Data Center. 

On the  popped up valids lists  window,

· highlight ECS-GSFC
·  click Add 

· Click OK.to dismiss valids lists window 

· Click on List of Data Set.

On the popped up valids lists window, 

· highlight test data set (eg. ASTER Expedited data) 

· click Add 

· Click OK to dismiss valids lists window

· Click on Geographic Area pull down menu and select Global Search.

· Click on Execute Search.

32
Ops Controller or Computer Operator
Wait until Data is lit up on Communication Status. 

· Click on Data. 

On the Inventory Results Screen that pops up, 

· Select Sreen Function / Turn on Granule Id

· Highlight the test data (eg. ASTER Expedited data) by clicking on it

· Change order status (column ‘O’) from N to Y by clicking on N

·  Click on Order Data
Note:  Search may find more than one set of test data, due to archiving of the same data more than once, possibly by other runs of the test. Identify test data by db_Id. at the end of the Granule Id.

33
Ops Controller or Computer Operator
Note:  This step is necessary only if this data has been acquired recently (in that case data is available at the staging disk cache and will not be fetched from the tape).

Use ECSAssist/HPOpenView to coldstart the staging Disk Server. Alternately, log on the Staging Disk Server machine (g0icg01), find the pid and owner of the STMGT staging disk server; kill the process and then coldstart the server:

· /usr/bin/ps -ef | grep EcDsStStagingDiskServer |grep <mode>(Note the owner name and  pid) 
· su <owner name>

· kill  -9 <pid>

·  cd /usr/ecs/<MODE>/CUSTOM/utilities 
· ls *Start* 
· EcDsStStagingDiskServerStart <MODE> StartTemperature cold
· Exit

34
Ops Controller or Computer Operator
Order test data. On the Order Data screen, 

· Highlight test data (eg. ASTER_EXP) in Package ID column. On the popped up Processing Option Selection,.
· Click on Package Options. 
· Select (Click to highlight) Processing Option as Native Granule Size=0, Media Type as FtpPull
· Click on OK to dismiss this pop-up. 
· Click on Submit Order.

35
Ops Controller or Computer Operator
Watch Order Status screen and wait for the e-mail to arrive. On the Z-mail GUI, double click on the new mail.  Check the directory indicated in the e-mail.

36
Ops Controller or Computer Operator
Compare the file size with the size stored in the science data server database. Change to the directory indicated in the e-mail and list its content.

· cd <directory name in e-mail>

· ls –alrt                         (identify the filenames)
· sum <filename>                  (for data and metadata)

37
Ops Controller or Computer Operator
Print the directory listing: In a Sun machine terminal,  

( setenv DISPLAY <terminal ID>:0.0
( xdpr -d<printer name>

( move the cross-bow to the directory listing widow

( press the left mouse button

(wait for 2 beeps before going back to the terminal window)

Compare the checksum of the original and acquired files.(the screen dumps may be useful) to verify that they are same.

Recovery of the primary copy

38
Ops Controller or Computer Operator
Study the archive server debug log. At g0drg01,

· cd /usr/ecs/<MODE>/CUSTOM/logs
· more  DsStArchiveServerDebug.log

39
Ops Controller or Computer Operator
The <primary path> and <backup path> that to be used here was obtained in step xxxx160).

Tester: Verify completion of data copying onto the Tape. On the ArchiveServer window,

( cd /usr/amass/bin

( dirfilelist –v <primary path>

40
Ops Controller or Computer Operator
Replace the corrupted file in the primary tape from the  backup tape

· cp <backup path>/filename <primary path>/filename
Find the checksum of the new copy of the file.

· sum <primary path>/filename

NON-ARCHIVE  BACKUP

Note: Execution of this part of the test requires both Sybase Database Administrator and Unix System Administrator priviledges

Perform Sysbase & unix tape back-up

41
Ops Controller or Computer Operator
Logon to a Sun machine, g0pls01 and get an x-terminal with large number of scroll lines:
· ssh <machine name> 
· Enter passphrase  
· setenv <terminal IP address>
· xterm –sb –sl 4444 &

42
Ops Controller or Computer Operator
Logon to the Science Data Server machine, g0acg01 and get two x-terminals with large number of scroll lines:
· ssh <machine name> 
· Enter passphrase 
· setenv <terminal IP address>
· xterm –sb –sl 4444 –n SQL &
· xterm –sb –sl 4444 –n DBDump &

43
Ops Controller or Computer Operator
Invoke Sysbase SQL.. (or continue on the SQL window opened earlier in step 30, if not exited out). 

· cd /usr/ecs/<MODE>/CUSTOM/utilities
· setenv  SYBASE  /tools/sybOCv11.1_32
· $SYBASE/bin/isql –U<username> -P<password> -S g0acg01_srvr

44
Ops Controller or Computer Operator
Perform a query.

· use EcDsScienceDataServer1_<MODE>
(Do not use mode suffix, _<mode> in OPS mode)

· go

· Select count(*) from  DsMdFileStorage

· go

Before the next step is completed, tester must execute the subsequent step (to verify accessibility of database during a database dump) So tester must get ready to perform a B0SOT

45
Ops Controller or Computer Operator
Generate a dump of the Sybase database on a disk file. At the DBDump window,  

· cd /usr/ecs/<MODE>/CUSTOM/Utilities

· DsDbDump  <mode>  <Username>  <Password>  g0acg01_srvr  EcDsScienceDataServer1_<mode>

(Do not use mode suffix, _<mode> in OPS mode)

46
Ops Controller or Computer Operator
Perform a data search from B0SOT. At g0ins02, repeat step xxxx690. Repeat a second time before the database dump is complete.

47
Ops Controller or Computer Operator
Check the existence of the dump file in the default directory. On the DBDump window.(g0acg01),

· cd /usr/ecs/<MODE>/COTS/sybase/sybase_dumps 
· ls –alrt

48
Ops Controller or Computer Operator
Create a file to be deleted and recovered. On the DBDump window

· cd /usr/ecs/<MODE>/CUSTOM/utilities

· ls

· cp  <filename>  testfile    (filename is any file from the listing obtained from the ls command)

· ls –alrt

49
Ops Controller or Computer Operator
Start the nwadmin GUI.  On the xterm,, 

· su
· Enter passphrase for root 
· cd /usr/ecs/<MODE>/COTS/nsr/bin
· ./nwadmin

50
Ops Controller or Computer Operator
Schedule Back up. From the Customize menu, 

· Select Schedule

51
Ops Controller or Computer Operator
Override current schedule. On the Schedule window,

· Click on <today’s date>  on the calendar. From the resulting menu,
· Select Overrides. From the next resulting menu,
· Select Full

· Click on Apply

52
Ops Controller or Computer Operator
From File menu

·  select Exit.

Open Group Control Gui. On the GUI,

· Click on Group Control button.

Start the backup process. On the new window,

· Click on start button. On the popped up notice window,

· Click on OK to dismiss the notice

Select Exit from File menu.

53
Ops Controller or Computer Operator
Repeat the above steps from xxxx1450 through xxxx1600 to perform a backup of g0pls01 machine.

54
Ops Controller or Computer Operator
Review the log of latest Sysbase database backup activity (backup is done by a cron job at regular interval). Note the time taken to perform the backup. Logon to the all the machine on which Sybase database runs (g0acg01, g0dmh02, g0icg01, g0icg02, g0ins02, g0ins01, g0msh08, g0mss21, g0pls02, g0mss20, g0sps06) and run vi.:

· cd /usr/ecs/<MODE>/COTS/sybase/install
· ls            (to get the backup log file name) 

· vi <filename>          (e.g.  g0acg01_backup.log)

· /<today’s date in appropriate format>         (within  vi)

The log file is long. Above search command will move the cursor to the interesting spot quickly but has to entered in appropriate format: Mon dd (e.g. Oct 30)

55
Ops Controller or Computer Operator
Verify the Networker backup log file. Log into g0sps06 and look for the backed up files in the log file. 

· cd /var/adm/SYSLOG

· ls -alrt

Delete files and database tables

56
Ops Controller or Computer Operator
Delete the files testfile from both Sun and SGI machines: At g0pls01 window,

· cd /usr/<MODE>/CUSTOM/utilities

· rm testfile 

· ls –alrt
Repeat it at g0acg01 machine at DBDump window.

57
Ops Controller or Computer Operator
Drop the Science data server database tables. At the DBDump window,  

· cd /usr/ecs/<MODE>/CUSTOM/Utilities

· DsDbDrop  <MODE>  <Username>  <Password>  g0acg01_srvr  EcDsScienceDataServer1_<mode>

(Do not use mode suffix, _<mode> in OPS mode)

58
Ops Controller or Computer Operator
Repeat the query. At the SQL command prompt,

· use EcDsScienceDataServer_1<MODE>

(If not in OPS Mode, append this command by _<mode>)
· go

· Select  * from  DsMdFileStorage

· go

59
Ops Controller or Computer Operator
Verify loss of normal operation by performing a data search from B0SOT. At g0ins02, repeat step 690. 

· Click on comment button when it lits up

60
Ops Controller or Computer Operator
Delete the database dump file. On the DBDump window,,

· cd /usr/ecs/<MODE>/sybase/sybase_dumps 
· rm EcDsScienceDataServer1.testdump
· ls  –alrt

Recover the files and database tables

61
Ops Controller or Computer Operator
Invoke NetWorker Recovery GUI. At g0acg01,

· cd /usr/ecs/<MODE>/COTS/nsr/bin 

· nwrecover

62
Ops Controller or Computer Operator
Select Files to be restored and click mark button Drag scroll bar with mouse to scroll the list 

Select the files <dbdumpfile> and testfile (that were deleted)

63
Ops Controller or Computer Operator
Start the recovery process. 

· Click on Start button
On the pooped up conflict resolution window, to the question “Do you want to be consulted for conflicts”

· Click on Yes

· Click on OK 

Note: If prompted with a conflict, select the appropriate choice from the menu.

64
Ops Controller or Computer Operator
At completion of recovery, exit the GUI.

· Click on Cancel
· Select Exit from File menu

65
Ops Controller or Computer Operator
Repeat above steps to recover the file (testfile) that was deleted from the Sun machine, g0pls01

66
Ops Controller or Computer Operator
Tester: Verify restoration of the files testfile in both Sun and SGI machines: At g0acg01,

· cd /usr/<MODE>/CUSTOM/utilities
· ls –alrt
Repeat it at g0icg01 machine

67
Ops Controller or Computer Operator
Restore Sybase science data server database from the recovered. file,  At DBDump window,  

· cd /usr/ecs/<MODE>/CUSTOM/Utilities

· DsDbLoad  <MODE>  <Username>  <Password>  g0acg01_srvr  EcDsScienceDataServer1_<mode>

(Do not use mode suffix, _<mode> in OPS mode)

68
Ops Controller or Computer Operator
Repeat the query. On the SQL prompt,

· use EcDsScienceDataServer_1<MODE>

· go

· Select count(*) from  DsMdFileStorage

· go

69
Ops Controller or Computer Operator
(If necessary, depending on the other activity in the DAAC) Restart the science data server. At  Science Data server machine (g0acs03),: 

· /usr/bin/ps -ef | grep EcDsScienceDataServer | grep <MODE>  (Note the pid and the owner of the process. If owner is not cmshared, contact owner. to provide help in killing the process )
( kill  -9  <pid>

Bring SDSRV back up, using HPOV, ECSAssist or command line; and watch the <dpr>.err log for completion of destaging. For command line option, in ScienceData window,

· cd /usr/ecs/<MODE>/CUSTOM/utilities
· EcDsScienceDataServerStart TS2.

70
Ops Controller or Computer Operator
Verify resumption of normal operation by performing a data search from B0SOT. At g0ins02, repeat step xxxx690.

71
Ops Controller or Computer Operator
Finish the test gracefully: 

( Exit out of all open GUIs
( terminate all processes

( logoff from all windows and terminals

ORE-13: Step-By-Step Procedures


Step No.
Input Action

Objective  – 5: Recovery From Abnormal Non-Catastrophic Shutdown

Science Data Server failure/restart

Assumptions: ACT PGE is available to create a production request..

1
Ops Controller or Computer Operator
Obtain the necessary X-windows. 

Log into a Planning machine, g0pls01, get an X-window titled “Planning” with appropriate environment and directory:

· xterm –sb –sl 5000 –n “Planning ” &

· setenv DISPLAY <Terminal/IP address>:0.0

· setenv ECS_HOME /usr/ecs

· cd /usr/ecs/<mode>/CUSTOM/utilities

Repeat the steps for Processing machine, g0sps06:

· xterm –sb –sl 5000 –n “ProcessingLog” &

· setenv DISPLAY <Terminal/IP address>:0.0

· cd /usr/ecs/<mode>/CUSTOM/logs

Repeat on same machine but log in as cmshared:

· xterm –sb –sl 5000 –n “Autosys” &

· setenv DISPLAY <Terminal/IP address>:0.0

· setenv ECS_HOME /usr/ecs

· cd /usr/ecs/<MODE>/CUSTOM/utilities

Repeat onScience Data Server machine, g0acs03, but log in as cmshared:

· xterm –sb –sl 5000 –n “ScienceData” &

· cd /usr/ecs/<MODE>/CUSTOM/utilities

2
Ops Controller or Computer Operator
Start Autosys JobScape. On the Autosys window, (use instance = FMR): 

· EcDpPrAutosysStart <MODE> <instance>

· On the invoked Autosys GUI, Click on JobScape

3
Ops Controller or Computer Operator
Start the Production Request GUI (app-ID is a number between 1 and 5) and Create  a Production Request TEST140_PR:

On the Planning window,  

· dce_login <username><password>

· EcPlPRE_IFStart <MODE> 

In the invoked Production Request GUI, 

· Click on the PR Edit button

· Click on the PGE button

· Select ACT

· Click on OK 

· Start Time: 07 04 1997   13 01 23

· End Time:  07 04 1997   13 01 24

· Select File/Save As:&

· enter file name TEST140 _PR

· Click on OK. Watch for message “1 DPR(s) generated”

· Select File/Exit

4
Ops Controller or Computer Operator
Start  the Planning Workbench GUI (must use same app-ID): 

· EcPlStartAll <MODE> <app-ID>

From the invoked Planning Workbench GUI,

·  Select File/New, enter <TEST140_PLAN>

(  Click on Apply & OK.

(  Highlight: TEST140_PR

(  Click on the down-arrow

· Select File/Save

· Click on Activate button.

5
Ops Controller or Computer Operator
Get ready to kill the SDSRV (see next step. Use Autosys to hold the destaging job if needed). Enter the following start date and time values in the Activation pop-up:

( <today’s date - mm/dd/yyyy> 00:00:00

( <today’s date - mm/dd/yyyy> 23:00:00

( Click on the ‘OK’ button. 

· Select File/Exit

6
Ops Controller or Computer Operator
Let processing of the DPR continue until it reaches the destaging state.  Kill SDSRV just after destaging has begun. Look for error messages in the <dpr>.err log and an Autosys error flag. In the ProcessingLog window,
( tail -f <dprid>.err 

On the ScienceData window (machine g0acs03): 

· /usr/bin/ps -ef | grep EcDsScienceDataServer | grep <MODE>                                (Note the pid)
( kill -9 <pid>.

7
Ops Controller or Computer Operator
Bring SDSRV back up, using HPOV and watch the <dpr>.err log for completion of destaging.

STMGT Server failure/cold start & resource cleanup

8
Ops Controller or Computer Operator
Assumption:  The INGEST related servers are up.  Verify using the ECS Assist Monitor screen (on g0icg01) that the following servers are running:

EcInAuto

EcInReqMgr

EcInPolling.FDD

EcInPolling.EDOS

EcInPolling.IAS

EcInPolling.NCEP

EcInPolling.SCF

EnInGran

Note:  At the start of the test, ingest client machine (g0icg01) polling directory, /usr/ecs/<mode>/CUSTOM/data/INS/pollAM1ATTF must not contain the Definitive Attitude data file, AM1_DEFATT_010000_181_1998_01.FDD. 

If needed, Clean up the polling directory  and delete /usr/ecs/<MODE>/CUSTOM/data/INS/local/FDD/Response/FDD.oldList

9
Ops Controller or Computer Operator
Obtain the necessary X-windows. 

Log into a Ingest Client machine, g0acs02 as cmshared, get an X-window titled “IngestGUI” with appropriate environment and directory:

· xterm –sb –sl 5000 –n “IngestGUI” &
· setenv DISPLAY <Terminal/IP address>:0.0
· cd /usr/ecs/<MODE>/CUSTOM/utilities
Repeat the steps for STMGT server, g0icg01:

· xterm –sb –sl 5000 –n “IngestLog” &
· setenv DISPLAY <Terminal/IP address>:0.0
· cd /usr/ecs/<MODE>/CUSTOM/logs
Repeat on same machine but log in as cmshared:

· xterm –sb –sl 5000 –n “StagingDisk” &
· setenv DISPLAY <Terminal/IP address>:0.0
· cd /usr/ecs/<MODE>/CUSTOM/utilities

10
Ops Controller or Computer Operator
On IngestGUI window (g0acs02) start ingest GUI:

· EcInGUIStart <MODE>
On the  invoked INGEST GUI, 

· select the “Operator Tools” function.

On the “Operator Tools” screen, perform the following steps/commands:

· enter FDD as the External Data Provider

· set the priority to Low
· click the OK button

On the INGEST GUI

· select the “Monitor/Control” function.

On the “Monitor/Control” screen, perform the following steps/commands:

· select Search By: Data Provider
· enter FDD
· select Text View
NOTE:  Disregard repetitive pop-up windows.  An NCR has been generated to try and resolve this problem.  The current work around is to move the message window to a corner of the screen.

11
Ops Controller or Computer Operator
On the StagingDisk window (g0icg01), find the pid of the STMGT staging disk server and kill the process:

· /usr/bin/ps -ef | grep EcDsStStagingDiskServer |grep <MODE> (Note the pid.)

( kill  -9 <pid>

12
Ops Controller or Computer Operator
Note: This step will be executed only if the necessary file has not already been placed in the designated directory.
Copy the Definitive Attitude data file to the Definitive Attitude directory:

· cd <directory containing Definitive Attitude data file>

· ls - al
· cp <Definitive Attitude data file> ./pollAM1ATTF (copy definitive attitude data file to polling directory)

Reviews the Monitor/Control display. Note the Request ID displayed on the screen. Watch the log file EcInGran1.Alog. On the IngestLog window (g0icg01),

· tail  -f  EcInGran.Alog
Cold start the STMGT staging disk server on g0icg01:

( cd /usr/ecs/<MODE>/CUSTOM/utilities 
( ls *Start* 
· EcDsStStagingDiskServerStart <MODE> StartTemperature cold



13
Ops Controller or Computer Operator
· Double click on the ingest request to get granule specific information.

· Inspect the Ingest GUI Monitor/Control Screen

14
Ops Controller or Computer Operator
Views the EcInGran1.ALOG to verify successful ingest and preprocessing of the data on the Logs window: On StagingDisk window:

· cd /usr/ecs/<MODE>/CUSTOM/logs
· more EcInGran.ALOG
· /Staging (search for the word “Staging”); will see the following message => “Staging disk allocation succeeded for request #”

· /preprocessing (search for the word “preprocessing”); will see the following message => “Metadata preprocessing successful”

· /Insert (search for the word “Insert”); will see the following message => GranInsert (Request ID = #, Provider = FDD, Collection name = AM1ATTF)

DDIST Server Failure/Restart

15
Ops Controller or Computer Operator
Assumption:  The following servers are up.  Verify, using the ECS Assist Monitor screen or other means: 

on g0acs03, EcDsScienceDataServer,               

on g0dis02,  EcDsDistributionServer,

on g0drg01,  EcDsStStagingDiskServer,

on g0drg01, EcDsStStagingMonitorServer,

on g0drg01, EcDsStArchhiveServer,

on g0drg01, EcDsStFtpDisServer,

on g0acg01, EcDsStPullMonitorServer,

on g0ins02, EcDmEcsToV0Gateway,

on g0ins02, EcDmV0ToEcsGateway,

on g0ins02, EcDmDictServer,

on g0ins02, EcClDtUserProfileGateway,

on g0mss21, EMsAcOrderSrvr.

16
Ops Controller or Computer Operator
Login to the CLS, g0ins02. Start the B0SOT GUI:

· setenv DISPLAY <Terminal/IP address>:0.0
· xterm –sb –sl 5000 –n “B0SOT GUI” &
· cd /usr/ecs/<MODE>/CUSTOM/bin/CLS
· source runrc_cls
· desktop

17
Ops Controller or Computer Operator
· Log in as and Select B0SOT  on the popped up Desktop menu, by double clicking on B0SOT icon.

· Select User Profile and on the new pop-up screen, fill up user address information (may be fictitious but e-mail address must be correct) and click on save. Repeat for billing and shipping address (convenient to use “copy from user address” feature). Click on close after all three addresses are saved.

18
Ops Controller or Computer Operator
· Click on Search Screen and Select Inventory on the popped up GUI.

· Click on List of Data Center, highlight ECS-GSFC, click Add and OK.

· Click on List of Data Set, highlight MODIS Geolocation, click Add and OK. 

· Click on Geographic Area and select Global Search.

· Click on Execute Search and wait until Data is lit up on the new pop.

19
Ops Controller or Computer Operator
Wait until Data is lit up on Communication Status. 

· Click on Data. 

On the Search Results GUI that pops up, 

· Select the first data set by changing its order status (‘O’) from N to Y. 

· Click Order Data.

Log into the DDIST machine, g0dis02,  and kill the DDIST server: 

· /usr/bin/ps -ef |grep EcDsDistributionServer |grep <mode> .    Note the pid. 

· kill -9 <pid>.

20
Ops Controller or Computer Operator
Log into on Pull Monitor Server machine, g0acg01. Watch the EcDsStPullMonitorServerDebug.log file:

· cd /usr/ecs/<MODE>/CUSTOM/logs

· tail -f EcDsStPullMonitorServerDebug.log

21
Ops Controller or Computer Operator
On the Order Data screen,

· highlight Package ID,

· Click on Package Options, 

· Select Processing Option as Native Granule Size=0, Media Type as FtpPull, 

· Click on OK and click on Submit Order. 

Watch Order Status screen.

22
Ops Controller or Computer Operator
Restart (warm) the DDIST server from the HPOV. Watch the log file and wait for the e-mail to arrive.  Check the directory indicated in the e-mail.  Command line mail.

File Recovery

23
Ops Controller or Computer Operator
Execute a simulated FSMS Server Host disc crash.  View HP OpenView.

· Double click on the GSFC icon to go down to the next level of submaps.

· Double click on the DRPHW-GSFC-1 icon to go down to the next level of submaps.

Fails to write to the disk.  Then, determines the disk has crashed.

· Initiate the archive media recovery utility

Schedules the replacement and restoration of the disk with the DAAC Resource Manager and the DAAC Production Monitor.

24
Ops Controller or Computer Operator
· Notify all affected users that the system has crashed and a restore is scheduled for 0100.  This message also indicates which date the backup that is be used was taken.

· Retrieves the backup which is stored in a different facility.

· Enters the commands to initialize the scripts to begin the restore.

· Invokes the word processor and selects “Open” from the file pull down menu to review the log file associated with the backup being restored.

25
Ops Controller or Computer Operator
· Select the Restore xxxxxx.log (where xxxxxx equal the month, day and year).

· Print out a copy of the log file.

· Exit the log file directory.

· Restore the incremental backups taken since the last system backup to bring the system as close to real-time as possible.  (The latest backup is determined by opening the inc_bkup_doc file from the word processor and viewing a list of the latest incremental backups).

26
Ops Controller or Computer Operator
· From the word processor that is already up, opens the file pull down menu and selects open.  Then, selects the associated QA report and opens it.

· Compare the QA report with the log file from the backup that was restored.

· Verifies that the system is back up and operational.

· Notifies, via email, the affected users that the restore has concluded and that activities that were performed before Day 5 at 1900 may need to be redone.

· Simulate a failure in the WKSHW RAID storage device.

27
Ops Controller or Computer Operator
· Log in to a DAAC workstation.

Note: RAID is still down and the system is able to use other lower capacity disk resources in order to continue functioning with degraded performance.

28
Ops Controller or Computer Operator
· Bring up the accountability Management tool.
· Enter commands to place an order for a user to receive science data.
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